bim:get-namespace-label


(bim:get-namespace-label nameSpace)

Returns the label of the specified nameSpace.

Arguments

nameSpace  (string) the NameSpace to verify (can be the "name" or the "label" of a BIM NameSpace)

Return

label (string) of the NameSpace, or NIL in case of failure

Example

(vl-load-bim)
(bim:create-namespace "MyNameSpace" "MyNameSpace-X" T)
(bim:get-namespace-label "MyNameSpace")  "MyNameSpace"
(bim:get-namespace-label "MyNameSpace-X")  "MyNameSpace"

Remarks

the nameSpace is not case-sensitive; both "name" and "label" of a BIM NameSpace are verified



©  Bricsys NV. All rights reserved.