bim:get-spaceobjects


(bim:get-assigned-space  name|ename)

Returns the list of entities which are assigned to the specified 'Space' object.

Arguments

name  (string) the name of the space to query, as normal entity or as VLA object name

or

ename  (entity name) the ENAME of the space to query

Return

list of ENAME, or NIL if no entity is assigned to the space object, of if that space does not exist

Example

(setq ent (car (entsel)))  <Entity name: 81c370d0>
(bim:get-spaceobjects ent) (<Entity name: 81c36e50>)

(bim:get-spaceobjects "Kitchen")  (<Entity name: 81c50290>)

Remarks

important : the name of a space is not unique ! Unique identifiers are the GUID and also the "Number" of the space;



©  Bricsys NV. All rights reserved.