civil:converter-get-c3d-profiles


(civil:converter-get-c3d-profiles  handle)

Returns list of all profile entity handles for the specified C3D ProfileView entity handle (integer).

Arguments

handle  (handle, integer)  the C3D entity to retrieve the alignment type for

Return

the list of C3D profile entities (list of integer handles) on success, or NIL if the specified handle does not refer to a C3D ProfileView entity)

Example

(vl-load-civil)
(setq converter (civil:get-converter 255))  1860981280
(setq c3dents (civil:converter-get-c3d-entities converter))  (1719921328  1855578352  1719922032  1855582912  1855579152)
(setq handle (nth 0 c3dents))  2093508048
(setq profile (civil:converter-get-c3d-profiletype handle))  NIL
(setq handle (nth 1 c3dents))  2093507408
(setq profiles (civil:converter-get-c3d-profiles handle))  (2093979968 2093978608)

Remarks




©  Bricsys NV. All rights reserved.