civil:pgroup-get-point


(civil:pgroup-get-point  groupNameOrEname  pointNumber)

Returns the ename of the C3D Point specified by its pointNumber, in specified C3D PointGroup groupNameOrEname.

Arguments

groupNameOrEname  (string or ename)  the name (string) or ENAME of the PointGroup to retrieve the number of points
pointNumber  (integer >= 0)  the point to check for containment

Return

ENAME of the C3D point, or NIL if pointNumber is not contained in the groupNameOrEname PointGroup

Example

(vl-load-civil)  T
(setq group (civil:pgroups-get "_All points"))  <Entity name: 6df86cd0>
(setq pnt (civil:pgroup-get-point group 5))  <Entity name: 6df85ed0>

Remarks




©  Bricsys NV. All rights reserved.