civil:point-file-formats
(civil:point-file-formats
[filename])
Returns all available Civil point file
formats, or (optionally) only those Civil point file formats which
match the structure of provided file filename.
Arguments
|
filename (string, optional) if argument is not provided
(or NIL), then all available point file format names are
returns;
if provided as a valid, existing disk file,
only those format names are returned which match the structure of
the provided filename
|
Return
|
list of format name strings,
or NIL
|
Example
|
(vl-load-civil)
T
(setq res
(civil:point-file-formats))
("ENZ (comma delimited)" "ENZ (semicolon
delimited)" "ENZ (space delimited)" "NEZ (comma delimited)" "NEZ
(semicolon delimited)" "NEZ (space delimited)" "PENZ (comma
delimited)" "PENZ (semicolon delimited)" "PENZ (space delimited)"
"PENZD (comma delimited)" "PENZD (semicolon delimited)" "PENZD
(space delimited)" "testPointFileFormat1" "testPointFileFormat2"
"testSurfFileFormat1" "testSurfFileFormat2")
(setq res (civil:point-file-formats (findfile
"civil_points_1.txt")))
("ENZ (comma delimited)" "NEZ (comma
delimited)" "PENZ (comma delimited)" "PENZD (comma delimited)"
"testPointFileFormat1" "testPointFileFormat2" "testSurfFileFormat1"
"testSurfFileFormat2")
|
Remarks
|
the format name can then be
used in (civil:point-import-file)
function
|