vl-vector-project-pointToEntity


(vl-vector-project-PointToEntity  point  viewDir  entity)

Returns the point projected with given viewDir onto the entity.

Arguments

point  the point to be projected ( list of x y z)

viewDir  the view direction to be used (from point to entity), (list of x y z)

entity  the entity to project the point to (ENAME or VLA object)

Return

the point (list x y z) on the entity, or NIL if projection does not end-up on the entity's sirface

Example


Alias


Remarks

supported entity types :

- closed curves (like Circle, 2dPolyline, LwPoyline), handled like a "filled area" (3dPolyline entities are *not* supported !)
- Regions
- 3dSolids
- Surfaces
- 3dFace
- PolyfaceMesh
- PolygonMesh



©  Bricsys NV. All rights reserved.