LISP Compatibility

Functions Unique to Bricscad LISP

The following functions are unique to the implementation of LISP included with Bricscad:

Function Comments
Lpad Pads a text string with spaces to the left.
Rpad Pads a text string with spaces to the right.
Tan Returns the tangent.
Trim Trims spaces from a string.

 

LISP-Compatible Functions with Enhanced Features

The following LISP functions in Bricscad have enhanced features.

Osnap in Bricscad supports these additional entity snap modes:

Mode Meaning
"po" POint
"pla" PLAnview (2D intersection)
"vis" VISible (apparent intersection)

 

The functions ssget and ssadd in Bricscad recognize these additional selection set parameters:

Mode Meaning Points Example
"CC" Crossing Circle point1 point2 (ssget "CC" '(1 1) '(2 2))
"O" Outside points-list (ssget "O" ptlist)
"OC" Outside Circle point1 point2 (ssget "OC" '(1 1) '(2 2))
"OP" Outside Polygon points-list (ssget "OP" ptlist)
"PO" POint point1 (ssget "PO" '(1 1))

 

Functions Partially Compatible with LISP in Other CAD Systems

The following function is partially compatible with the LISP found in other CAD systems:

Function Comments
menucmd Bricscad supports P0 (cursor menu) and P1 through P16 (the pulldown menus). Bricscad does not support A (aux menus), B (button menus), I (icon menus), M (diesel expressions), S (screen menu), or T (tablet menus).

 

 

Tell me about...

Copying Code Examples from the Bricscad Programmer’s Reference

Programming Overview of LISP (LISt Processing) Language

LISP Encryption


Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV are fully owned subsidiaries of Menhirs NV. © 2001- Menhirs NV - All rights reserved.