ArrayRectangular method

Creates a rectangular array.

 

Syntax

objectVariable = object.ArrayRectangular(NumberOfRows, NumberOfColumns, [NumberOfLevels], GapBetweenRows, GapBetweenColumns, [GapBetweenLevels])

Where:

object is one of the ModelSpace or PaperSpace collection objects or a Block object;

NumberOfRows is the number of rows (horizontal elements) in the array;

NumberOfColumns is the number of rows (vertical elements) in the array;

NumberOfLevels is the number of levels in a 3D array;

GapBetweenRows is the distance between rows. A positive number causes the array to be built to the right of the source object, while a negative number causes the array to be built to the left.

GapBetweenColumns is the distance between rows. A positive number causes the array to be built upward, while a negative number causes the array to be built downward.

GapBetweenLevels is the distance between levels. A positive number causes the array to be expanded in the positive direction, while a negative number causes the array to be expanded in a negative direction.

 

Examples...

ArrayRectangular method example

 


Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV are fully owned subsidiaries of Menhirs NV. © 2001- Menhirs NV - All rights reserved.