Class AcadArc
Member of BricscadDb
The Arc object represents a segment of a circle or ellipse. To create an arc, use either the AddArc method. To access the Arc object, use the following methods and properties.
Methods | Properties |
---|---|
ArrayPolar | Application |
ArrayRectangular | ArcLength |
Copy | Area |
Delete | Center |
GetBoundingBox | Document |
GetExtensionDictionary | EndAngle |
GetXData | EndPoint |
Highlight | Handle |
IntersectWith | HasExtensionDictionary |
Mirror | Hyperlinks |
Mirror3D | Linetype |
Move | LinetypeScale |
Offset | Lineweight |
Rotate | Material * |
Rotate3D | Normal |
ScaleEntity | ObjectID |
SetXData | ObjectName |
TransformBy | OwnerID |
Update | PlotStyleName |
Radius | |
StartAngle | |
StartPoint | |
Thickness | |
TotalAngle | |
TrueColor | |
Visible |
© Bricsys NV. All rights reserved. |