Class AcadHatch
Member of BricscadDb
The Hatch object represents an area fill consisting of a pattern of lines. To create a hatch, first create the Hatch object using the AddHatch method. To query or edit an existing block reference, use the following methods and properties:
Methods | Properties |
---|---|
AppendInnerLoop | Application |
AppendOuterLoop | Area |
ArrayPolar | AssociativeHatch |
ArrayRectangular | Document |
Copy | Elevation |
Delete | GradientAngle |
GetBoundingBox | GradientCentered |
GetExtensionDictionary | GradientColor1 |
GetLoopAt | GradientColor2 |
GetXData | GradientName |
Highlight | Handle |
InsertLoopAt | HasExtensionDictionary |
IntersectWith | HatchObjectType |
Mirror | HatchStyle |
Mirror3D | Hyperlinks |
Move | ISOPenWidth |
Rotate | Layer |
Rotate3D | Linetype |
ScaleEntity | LinetypeScale |
SetPattern | Lineweight |
SetXData | Material |
TransformBy | Normal |
Update | NumberOfLoops |
ObjectID | |
ObjectName | |
OwnerID | |
PatternAngle | |
PatternDouble | |
PatternName | |
PatternScale | |
PatternSpace | |
PatternType | |
TrueColor | |
Visible |
© Bricsys NV. All rights reserved. |