Matrix2dAlignCoordinateSystem
Method
|
Returns the matrix that maps the coordinate
system defined by the fromOrigin origin and the fromE0 and fromE1
axes, to the coordinate system defined by the toOrigin origin and
the toE0 and toE1 axes.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public static Matrix2d AlignCoordinateSystem(
Point2d fromOrigin,
Vector2d fromE0,
Vector2d fromE1,
Point2d toOrigin,
Vector2d toE0,
Vector2d toE1
)
Public Shared Function AlignCoordinateSystem (
fromOrigin As Point2d,
fromE0 As Vector2d,
fromE1 As Vector2d,
toOrigin As Point2d,
toE0 As Vector2d,
toE1 As Vector2d
) As Matrix2d
public:
static Matrix2d AlignCoordinateSystem(
Point2d fromOrigin,
Vector2d fromE0,
Vector2d fromE1,
Point2d toOrigin,
Vector2d toE0,
Vector2d toE1
)
static member AlignCoordinateSystem :
fromOrigin : Point2d *
fromE0 : Vector2d *
fromE1 : Vector2d *
toOrigin : Point2d *
toE0 : Vector2d *
toE1 : Vector2d -> Matrix2d
Parameters
- fromOrigin Point2d
- [in] Origin of the initial coordinate system.
- fromE0 Vector2d
- [in] X-axis of the initial coordinate system.
- fromE1 Vector2d
- [in] Y-axis of the initial coordinate system.
- toOrigin Point2d
- [in] Origin of the target coordinate system.
- toE0 Vector2d
- [in] X-axis of the target coordinate system.
- toE1 Vector2d
- [in] Y-axis of the target coordinate system.
Return Value
Matrix2d
See Also