Matrix2d Structure

This class represents 2D transformation matrices that define affine ( translation, rotation, and/or scaling ) transformations.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryMatrix2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public struct Matrix2d : IFormattable

The Matrix2d type exposes the following members.

Constructors
  Name Description
Public method Matrix2d Constructor for the Matrix2d class. Creates a matrix with elements taken from the passed array.
Top
Properties
  Name Description
Public property CoordinateSystem2d  
Public property ElementAt Property that represents an element of this matrix at the specified row and column indices.
Public property Translation  
Top
Methods
  Name Description
Public methodStatic member AlignCoordinateSystem Returns the matrix that maps the coordinate system defined by the fromOrigin origin and the fromE0 and fromE1 axes, to the coordinate system defined by the toOrigin origin and the toE0 and toE1 axes.
Public methodStatic member Displacement Returns the displacement (translation) matrix by the specified vector.
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetDeterminant Returns the determinant of this matrix.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetScale Returns the scale factor of this matrix. The scale factor is the square root of the longest column vector of the linear part of this matrix.
Public method Inverse Returns the inverse of this matrix.
Public method IsConformal Checks whether this matrix is conformal (isUniScaledOrtho()), and returns the matrix information that contains the scale factor, angle of rotation, the presence of a mirror component to the matrix, and the direction of reflection.
Public method IsEqualTo(Matrix2d) Checks whether this matrix is equal to the passed matrix.
Public method IsEqualTo(Matrix2d, Tolerance) Checks whether this matrix is equal to the passed matrix according to the specified tolerance.
Public method IsScaledOrtho Checks whether the column vectors of the linear part of this matrix are perpendicular to each other.
Public method IsScaledOrtho(Tolerance) Checks whether the column vectors of the linear part of this matrix are perpendicular to each other according to the specified tolerance.
Public method IsSingular Checks whether this matrix is singular.
Public method IsSingular(Tolerance) Checks whether this matrix is singular according to the specified tolerance.
Public method IsUniscaledOrtho Checks whether the column vectors of the linear part of this matrix are of equal length and perpendicular to each other.
Public method IsUniscaledOrtho(Tolerance) Checks whether the column vectors of the linear part of this matrix are of equal length and perpendicular to each other according to the specified tolerance.
Public methodStatic member Mirroring(Line2d) Returns the matrix that mirrors about the specified line.
Public methodStatic member Mirroring(Point2d) Returns the matrix that mirrors about the specified point.
Public method Multiply Multiplies the specified matrix with this matrix. This method is identical to the PreMultiplyBy method which sets this matrix to the product of matrix * (this matrix).
Public method PostMultiplyBy Sets this matrix to the product of (this matrix) * rightSide and returns the resulting matrix.
Public method PreMultiplyBy Sets this matrix to the product of leftSide * (this matrix) and returns the resulting matrix.
Public methodStatic member Rotation Returns the matrix that rotates by angle about the center.
Public methodStatic member Scaling Returns the matrix that scales by a scale factor about the center.
Public method ToArray Returns an array that contains matrix elements. Matrix elements are assigned by rows (data11, data12 ... data33). The resulting array contains nine elements.
Public method ToString Returns a string representation of this matrix.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Public method ToString(String, IFormatProvider) Returns an equivalent string representation of this object.
Public method Transpose Returns the transpose of this matrix.
Top
Operators
  Name Description
Public operatorStatic member Equality(Matrix2d, Matrix2d) Equality operator for the Matrix2d structure. Checks whether matrix elements are equal.
Public operatorStatic member Inequality(Matrix2d, Matrix2d) Inequality operator for the Matrix2d structure. Checks whether matrix elements are not equal.
Public operatorStatic member Multiply(Matrix2d, Matrix2d) Multiplication operator for the Matrix2d structure. Multiplies the left matrix by the right matrix (a*b).
Top
Remarks
Matrix2d may be viewed as an array[3][3] of doubles. A Matrix2d, M, can be expressed as a 3 by 3 matrix, in the form
   a00   a01   t0
   a10   a11   t1
     0     0    1
The linear part of M is the matrix
   a00   a01
   a10   a11
The translational part of M is the column
   t0
   t1
The origin of the coordinate system of M is (t0, t1).
See Also

©  Bricsys NV. All rights reserved.