Returns the matrix that rotates by angle about
the center.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public static Matrix2d Rotation(
double angle,
Point2d center
)
Public Shared Function Rotation (
angle As Double,
center As Point2d
) As Matrix2d
public:
static Matrix2d Rotation(
double angle,
Point2d center
)
static member Rotation :
angle : float *
center : Point2d -> Matrix2d
Parameters
- angle Double
- [in] Rotation angle.
- center Point2d
- [in] Point about which to rotate.
Return Value
Matrix2d
See Also