FileDependencyManagerCreateEntry
Method
|
Creates an entry in the .dwg section of the
File Dependency List.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public int CreateEntry(
string feature,
string fullFileName,
bool affectsGraphics,
bool noIncrement
)
Public Function CreateEntry (
feature As String,
fullFileName As String,
affectsGraphics As Boolean,
noIncrement As Boolean
) As Integer
public:
int CreateEntry(
String^ feature,
String^ fullFileName,
bool affectsGraphics,
bool noIncrement
)
member CreateEntry :
feature : string *
fullFileName : string *
affectsGraphics : bool *
noIncrement : bool -> int
Parameters
- feature String
- [in] Name of the application or feature creating the
entry.
- fullFileName String
- [in] Full name of the file for the entry.
- affectsGraphics Boolean
- [in] Flag specifying whether the entry affects the screen
view.
- noIncrement Boolean
- [in] Flag specifying whether duplicate records are created
instead of incrementing the reference count of the existing
entry.
Return Value
Int32
Unique File Dependency List ID for the new entry, or 0 if not
successful.
See Also