FileDependencyManager Class

This class allows management of entries in the .dwg section of the File Dependency List.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesFileDependencyManager

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class FileDependencyManager : DisposableWrapper

The FileDependencyManager type exposes the following members.

Properties
  Name Description
Public property CountEntries Property that represents the number of unique entries in the .dwg section of the File Dependency List.
Public property IteratorNext Property that represents the index of the next entry in the .dwg section of the File Dependency List. The returned value may be used in the getEntry() and eraseEntry() methods.
Top
Methods
  Name Description
Public method CreateEntry Creates an entry in the .dwg section of the File Dependency List.
Public method EraseEntry(Int32, Boolean) Erases the specified entry from the .dwg section of the File Dependency List.
Public method EraseEntry(String, String, Boolean) Erases the specified entry from the .dwg section of the File Dependency List.
Public method GetEntry(Int32) Returns the specified entry in the .dwg section of the File Dependency List.
Public method GetEntry(Int32, Boolean) Returns the specified entry in the .dwg section of the File Dependency List.
Public method GetEntry(String, String) Returns the specified entry in the .dwg section of the File Dependency List.
Public method GetEntry(String, String, Boolean) Returns the specified entry in the .dwg section of the File Dependency List.
Public method IteratorInitialize Initializes an iterator for the .dwg section of the File Dependency List.
Public method UpdateEntry(Int32)  
Public method UpdateEntry(String, String)  
Top
Remarks
Every database instance has a permanent association with an instance of this class.
See Also

©  Bricsys NV. All rights reserved.