Point2dCollection Class

This class represents a collection of 2D points.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryPoint2dCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class Point2dCollection : DisposableWrapper, 
        IList

The Point2dCollection type exposes the following members.

Constructors
  Name Description
Public method Point2dCollection Default constructor for the Point2dCollection class. Creates an empty collection of 2D points.
Public method Point2dCollection(Int32) Constructor for the Point2dCollection class. Creates an empty collection of 2D points with start capacity.
Public method Point2dCollection(Point2d) Constructor for the Point2dCollection class. Creates a collection of 2d points from the passed array.
Top
Properties
  Name Description
Public property Capacity Represents the number of elements that this collection can contain.
Public property Count Represents the number of elements that this collection currently stores.
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Top
Methods
  Name Description
Public method Add Adds a point to the collection.
Public method AddRange Adds a range of points to the end of this collection. This method grows the collection capacity if necessary.
Public method Clear Clears this collection of 2D points.
Public method Contains Checks whether this collection contains a point that matches the specified point.
Public method CopyTo Copies this point collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this point collection.
Public method IndexOf Returns an index of the point in the collection that matches the specified point.
Public method Insert Inserts the specified point to the collection at the provided index.
Public method Remove Removes a point from the collection that matches the specified point.
Public method RemoveAt Removes a point from the collection at the specified index.
Public method ToArray Returns this collection as an array of 2D points.
Public method TrimToSize Sets the capacity to the actual number of elements in this integer collection.
Top
Fields
  Name Description
Public fieldStatic member DefaultSize Size of the default point collection.
Top
See Also

©  Bricsys NV. All rights reserved.