NurbCurve3dSetFitData(Point3dCollection, Vector3d, Vector3d) Method

Sets the fit data for this spline.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public void SetFitData(
        Point3dCollection fitPoints,
        Vector3d startTangent,
        Vector3d endTangent
)

Parameters

fitPoints  Point3dCollection
[in] Interpolation points.
startTangent  Vector3d
[in] Start tangent.
endTangent  Vector3d
[in] End tangent.
Remarks
Recomputes the spline from the input fit points and start and end tangents.
See Also

©  Bricsys NV. All rights reserved.