Returns the matrix that scales by a scale
factor about the center.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public static Matrix2d Scaling(
double scaleAll,
Point2d center
)
Public Shared Function Scaling (
scaleAll As Double,
center As Point2d
) As Matrix2d
public:
static Matrix2d Scaling(
double scaleAll,
Point2d center
)
static member Scaling :
scaleAll : float *
center : Point2d -> Matrix2d
Parameters
- scaleAll Double
- [in] Scale factor.
- center Point2d
- [in] Point about which to scale.
Return Value
Matrix2d
See Also