PointOnSurfaceGetTangentVector(Vector2d)
Method
|
Maps the specified vector to the tangent plane
of the surface at the point corresponding to the parameter.
Currently not implemented.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public Vector3d GetTangentVector(
Vector2d vector
)
Public Function GetTangentVector (
vector As Vector2d
) As Vector3d
public:
Vector3d GetTangentVector(
Vector2d vector
)
member GetTangentVector :
vector : Vector2d -> Vector3d
Parameters
- vector Vector2d
- [in] 2D vector.
Return Value
Vector3d
Remarks
The tangent vector
is mapped as follows:
tangentVector = GetUDerivative(1) * vector.x + GetVDerivative(1) * vector.y
See Also