PointOnSurface Class

This class represents points along 3D curves. The point representation includes its parameter value, its coordinates, the derivatives, and the normal of the surface at that point. For more information, see Working with Evaluator Classes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryPointEntity3d
          Teigha.GeometryPointOnSurface

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public sealed class PointOnSurface : PointEntity3d

The PointOnSurface type exposes the following members.

Constructors
  Name Description
Public method PointOnSurface Default constructor for the PointOnSurface class. Creates a default corresponding C++ object with a point on the XY plane with a parameter value of (0,0).
Public method PointOnSurface(Surface, Point2d) Constructor for the PointOnSurface class. Constructs a point that lies on a specified surface and has a specified parameter value for u-axis and v-axis.
Top
Properties
  Name Description
Public property Parameter  
Public property Surface  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetInverseTangentVector(Vector3d) Projects the specified vector to the tangent plane of the surface at the point corresponding to the parameter. Currently not implemented.
Public method GetInverseTangentVector(Vector3d, Point2d) Projects the specified vector onto the tangent plane at the specified point and returns the 2D parameter space vector that maps to this projected vector.
Public methodStatic member GetInverseTangentVector(Vector3d, Surface, Point2d) Projects the specified vector onto the tangent plane of the provided surface at the specified parameter point (u, v) and returns the 2D parameter space vector that maps to the projected vector. Currently not implemented.
Public method GetMixedPartial Returns the mixed partial derivative of the surface at the point on the surface. Currently not implemented.
Public method GetMixedPartial(Point2d) Returns the mixed partial derivative of the surface at the point corresponding to the parameter. The method also sets the specified 2D parameter point. Currently not implemented.
Public methodStatic member GetMixedPartial(Surface, Point2d) Returns the mixed partial derivative of the specified surface at the point corresponding to the parameter. Currently not implemented.
Public method GetNormal Returns the normal to the surface at the point corresponding to the parameter. Currently not implemented.
Public method GetNormal(Point2d) Returns the normal to the surface at the point corresponding to the parameter. Currently not implemented.
Public methodStatic member GetNormal(Surface, Point2d) Returns the normal to the specified surface at the point corresponding to the parameter. Currently not implemented.
Public method GetPoint(Point2d) Returns the 3D point that corresponds to a 2D parameter point on the surface. The method also sets the specified 2D parameter point.
Public methodStatic member GetPoint(Surface, Point2d) Returns the 3D point that corresponds to a 2D parameter point on the specified surface.
Public method GetTangentVector(Vector2d) Maps the specified vector to the tangent plane of the surface at the point corresponding to the parameter. Currently not implemented.
Public method GetTangentVector(Vector2d, Point2d) Maps the specified vector to the tangent plane of the surface at the specified parameter value. Currently not implemented.
Public methodStatic member GetTangentVector(Vector2d, Surface, Point2d) Maps the specified vector to the tangent plane of the surface at the specified parameter value. Currently not implemented.
Public method GetUDerivative(Int32) Returns the specified derivative of the surface in the U direction at the point corresponding to the parameter. Currently not implemented.
Public method GetUDerivative(Int32, Point2d) Returns the specified derivative of the surface in the U direction at the point corresponding to the parameter. The point argument updates the parameter of the surface. Currently not implemented.
Public methodStatic member GetUDerivative(Int32, Surface, Point2d) Returns the specified derivative of the surface in the U direction at the point corresponding to the parameter. Currently not implemented.
Public method GetVDerivative(Int32) Returns the specified derivative of the surface in the V direction at the point corresponding to the parameter. Currently not implemented.
Public method GetVDerivative(Int32, Point2d) Returns the specified derivative of the surface in the V direction at the point corresponding to the parameter. The point argument updates the parameter of the surface. Currently not implemented.
Public methodStatic member GetVDerivative(Int32, Surface, Point2d) Returns the specified derivative of the surface in the V direction at the point corresponding to the parameter. Currently not implemented.
Top
See Also

©  Bricsys NV. All rights reserved.