NurbCurve3d(Point3dCollection,
Vector3dCollection, Boolean) Constructor
|
Constructor for the NurbCurve3d class.
Constructs a 3D polynomial curve interpolating a given array of 3D
points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public NurbCurve3d(
Point3dCollection fitPoints,
Vector3dCollection fitTangents,
bool periodic
)
Public Sub New (
fitPoints As Point3dCollection,
fitTangents As Vector3dCollection,
periodic As Boolean
)
public:
NurbCurve3d(
Point3dCollection^ fitPoints,
Vector3dCollection^ fitTangents,
bool periodic
)
new :
fitPoints : Point3dCollection *
fitTangents : Vector3dCollection *
periodic : bool -> NurbCurve3d
Parameters
- fitPoints Point3dCollection
- [in] Array of 3D points through which to fit the curve.
- fitTangents Vector3dCollection
- [in] Vectors interpolating the curve's derivatives at the fit
points.
- periodic Boolean
- [in] Flag that specifies whether to make the curve periodic (a
closed curve).
Remarks
If isPeriodic =
true, the first and last fitPoints must be identical. The same must
be true for fitTangents.
See Also