ClientExtensiongetPropertyEnabled(Entity,
SubEntFlags, ListFullSubentityPath, Int32, String,
Boolean) Method
|
Namespace: Bricscad.Opm
Assembly: BrxMgd (in BrxMgd.dll) Version:
25.1.5.0
Syntax
public virtual bool getPropertyEnabled(
Entity entity,
SubEntFlags subentType,
List<FullSubentityPath> fspArray,
int propertyId,
string childName,
out bool hideDisabled
)
Public Overridable Function getPropertyEnabled (
entity As Entity,
subentType As SubEntFlags,
fspArray As List(Of FullSubentityPath),
propertyId As Integer,
childName As String,
<OutAttribute> ByRef hideDisabled As Boolean
) As Boolean
public:
virtual bool getPropertyEnabled(
Entity^ entity,
SubEntFlags subentType,
List<FullSubentityPath>^ fspArray,
int propertyId,
String^ childName,
[OutAttribute] bool% hideDisabled
)
abstract getPropertyEnabled :
entity : Entity *
subentType : SubEntFlags *
fspArray : List<FullSubentityPath> *
propertyId : int *
childName : string *
hideDisabled : bool byref -> bool
override getPropertyEnabled :
entity : Entity *
subentType : SubEntFlags *
fspArray : List<FullSubentityPath> *
propertyId : int *
childName : string *
hideDisabled : bool byref -> bool
Parameters
- entity Entity
-
- subentType SubEntFlags
-
- fspArray ListFullSubentityPath
-
- propertyId Int32
-
- childName String
-
- hideDisabled Boolean
-
Return Value
Boolean
See Also