ClientExtension Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.OpmClientExtension

Namespace: Bricscad.Opm
Assembly: BrxMgd (in BrxMgd.dll) Version: 25.1.5.0
Syntax
public abstract class ClientExtension : DisposableWrapper

The ClientExtension type exposes the following members.

Constructors
  Name Description
Public method ClientExtension Initializes a new instance of the ClientExtension class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method allEntityNames  
Public method allowPropertyPreview  
Public method beginPropertiesUpdate  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method endPropertiesUpdate  
Public method getApplicationName  
Public method getCategoryName(Int32)  
Public method getCategoryName(String)  
Public method getDynamicPropertyMap(Entity)  
Public method getDynamicPropertyMap(Entity, SubEntFlags, ListFullSubentityPath)  
Public method getNativePropertiesToDisable  
Public method getObjectName(Entity, SubEntFlags)  
Public method getObjectName(Entity, FullSubentityPath)  
Public method getPredefinedStrings(Entity, Int32, String)  
Public method getPredefinedStrings(Entity, FullSubentityPath, Int32, String)  
Public method getPredefinedStrings(Entity, SubEntFlags, ListFullSubentityPath, Int32, String)  
Public method getPropertyDescription  
Public method getPropertyEnabled(Entity, Int32, String, Boolean)  
Public method getPropertyEnabled(Entity, FullSubentityPath, Int32, String, Boolean)  
Public method getPropertyEnabled(Entity, SubEntFlags, ListFullSubentityPath, Int32, String, Boolean)  
Public method getPropertyMap  
Public method getPropertyMap(RXClass)  
Public method getPropertyMap(RXClass, SubEntFlags)  
Public method getPropertyName  
Public method getPropertyParent  
Public method getPropertyReadOnly(Entity, Int32, String)  
Public method getPropertyReadOnly(Entity, FullSubentityPath, Int32, String)  
Public method getPropertyReadOnly(Entity, SubEntFlags, ListFullSubentityPath, Int32, String)  
Public method getPropertyValue(Entity, Int32, String)  
Public method getPropertyValue(Entity, FullSubentityPath, Int32, String)  
Public method getPropertyValue(Entity, SubEntFlags, ListFullSubentityPath, Int32, String)  
Public method setPropertyValue(Entity, Int32, String, PropertyVariant)  
Public method setPropertyValue(Entity, FullSubentityPath, Int32, String, PropertyVariant)  
Public method setPropertyValue(Entity, SubEntFlags, ListFullSubentityPath, Int32, String, PropertyVariant)  
Public method supportsDynamicProperties  
Top
See Also

©  Bricsys NV. All rights reserved.