Solid3dCreateSweptSolid(Entity,
SubentityId, Entity, SweepOptions) Method
|
Creates a swept solid by sweeping a face along
the specified path.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual void CreateSweptSolid(
Entity sweepEntity,
SubentityId faceSubEntityId,
Entity pathEntity,
SweepOptions sweepOptions
)
Public Overridable Sub CreateSweptSolid (
sweepEntity As Entity,
faceSubEntityId As SubentityId,
pathEntity As Entity,
sweepOptions As SweepOptions
)
public:
virtual void CreateSweptSolid(
Entity^ sweepEntity,
SubentityId faceSubEntityId,
Entity^ pathEntity,
SweepOptions^ sweepOptions
)
abstract CreateSweptSolid :
sweepEntity : Entity *
faceSubEntityId : SubentityId *
pathEntity : Entity *
sweepOptions : SweepOptions -> unit
override CreateSweptSolid :
sweepEntity : Entity *
faceSubEntityId : SubentityId *
pathEntity : Entity *
sweepOptions : SweepOptions -> unit
Parameters
- sweepEntity Entity
- [in] Entity that contains a face for sweeping.
- faceSubEntityId SubentityId
- [in] Face's subentity ID.
- pathEntity Entity
- [in] Curve entity that determines the path to sweep along.
- sweepOptions SweepOptions
- [in] Sweep options.
Remarks
By default the
SweepOptions object has the SweepOptionsAlignOption.NoAlignment
value for alignment. Set the
SweepOptionsAlignOption.kAlignSweepEntityToPath value for the
alignment of the sweep options before calling this method. This
method is implemented only for the Spatial modeler.
See Also