FileDependencyManagerIteratorInitialize Method
|
Initializes an iterator for the .dwg section
of the File Dependency List.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public void IteratorInitialize(
string feature,
bool modifiedOnly,
bool affectsGraphicsOnly,
bool walkXRefTree
)
Public Sub IteratorInitialize (
feature As String,
modifiedOnly As Boolean,
affectsGraphicsOnly As Boolean,
walkXRefTree As Boolean
)
public:
void IteratorInitialize(
String^ feature,
bool modifiedOnly,
bool affectsGraphicsOnly,
bool walkXRefTree
)
member IteratorInitialize :
feature : string *
modifiedOnly : bool *
affectsGraphicsOnly : bool *
walkXRefTree : bool -> unit
Parameters
- feature String
- [in] Name of the application or feature creating the
entry.
- modifiedOnly Boolean
- [in] Flag specifying whether to return only modified
entries.
- affectsGraphicsOnly Boolean
- [in] Flag specifying whether to return only entries that effect
the screen view.
- walkXRefTree Boolean
- [in] Flag specifying whether to traverse the File Dependency
Lists of externally referenced drawings.
Remarks
If no arguments
are specified, all entries in the local list are traversed. The
first three provided parameters restrict the list of entries being
traversed.
See Also