Export_ImportExportSTL
Method
|
Exports an element to STL format.
Namespace: Teigha.Export_Import
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public static ErrorStatus ExportSTL(
Entity pEnt,
string strFileName,
bool bTextMode,
double dDeviation
)
Public Shared Function ExportSTL (
pEnt As Entity,
strFileName As String,
bTextMode As Boolean,
dDeviation As Double
) As ErrorStatus
public:
static ErrorStatus ExportSTL(
Entity^ pEnt,
String^ strFileName,
bool bTextMode,
double dDeviation
)
static member ExportSTL :
pEnt : Entity *
strFileName : string *
bTextMode : bool *
dDeviation : float -> ErrorStatus
Parameters
- pEnt Entity
- [in] Entity to export.
- strFileName String
- [in] File name.
- bTextMode Boolean
- [in] If true, exports to ASCII STL format, else to binary STL
format.
- dDeviation Double
- [in] Maximum allowed deviation.
Return Value
ErrorStatus
See Also