Constructor for the Matrix2d class. Creates a
matrix with elements taken from the passed array.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public Matrix2d(
double[] data
)
Public Sub New (
data As Double()
)
public:
Matrix2d(
array<double>^ data
)
new :
data : float[] -> Matrix2d
Parameters
- data Double
- [in] Array of values for the matrix.
Remarks
Matrix assigns
first nine elements of the specified array (matrix in homogeneous
coordinates). Matrix elements are set by rows (data11, data12 ...
data33).
See Also