PointOnSurfaceGetTangentVector(Vector2d,
Surface, Point2d) Method
|
Maps the specified vector to the tangent plane
of the surface at the specified parameter value. Currently not
implemented.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public static Vector3d GetTangentVector(
Vector2d vector,
Surface vectorSurface,
Point2d pointer
)
Public Shared Function GetTangentVector (
vector As Vector2d,
vectorSurface As Surface,
pointer As Point2d
) As Vector3d
public:
static Vector3d GetTangentVector(
Vector2d vector,
Surface^ vectorSurface,
Point2d pointer
)
static member GetTangentVector :
vector : Vector2d *
vectorSurface : Surface *
pointer : Point2d -> Vector3d
Parameters
- vector Vector2d
- [in] 2D vector.
- vectorSurface Surface
- [in] 3D surface.
- pointer Point2d
-
Return Value
Vector3d
Remarks
The tangent vector
is mapped as follows:
tangentVector = GetUDerivative(1) * vector.x + GetVDerivative(1) * vector.y
See Also