PointOnSurfaceGetTangentVector(Vector2d, Point2d) Method

Maps the specified vector to the tangent plane of the surface at the specified parameter value. Currently not implemented.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public Vector3d GetTangentVector(
        Vector2d vector,
        Point2d point
)

Parameters

vector  Vector2d
[in] 2D vector.
point  Point2d
[in] 2D parameter point on the surface.

Return Value

Vector3d
Remarks
The tangent vector is mapped as follows:
C#
tangentVector = GetUDerivative(1) * vector.x + GetVDerivative(1) * vector.y
See Also

©  Bricsys NV. All rights reserved.