Moves the current position of the file pointer
for this stream buffer object to the specified location.
Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public override ulong Seek(
long offset,
FilerSeekType seekType
)
Public Overrides Function Seek (
offset As Long,
seekType As FilerSeekType
) As ULong
public:
virtual unsigned long long Seek(
long long offset,
FilerSeekType seekType
) override
abstract Seek :
offset : int64 *
seekType : FilerSeekType -> uint64
override Seek :
offset : int64 *
seekType : FilerSeekType -> uint64
Parameters
- offset Int64
- [in] Number of bytes.
- seekType FilerSeekType
- [in] Seek type.
Return Value
UInt64
New position of the file pointer for this stream buffer.
Remarks
ValueDescriptionSEEK_SET Start of file. SEEK_CUR
Current position of file pointer. SEEK_END End of file.
See Also