FileStreamBuf Class

This class represents a file stream buffer for I/O operations.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeStreamBuf
          Teigha.RuntimeFileStreamBuf

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class FileStreamBuf : StreamBuf

The FileStreamBuf type exposes the following members.

Constructors
  Name Description
Public method FileStreamBuf(String) Creates a file stream buffer.
Public method FileStreamBuf(String, Boolean) Creates a file stream buffer.
Public method FileStreamBuf(String, Boolean, FileShareMode) Initializes a new instance of the FileStreamBuf class
Public method FileStreamBuf(String, Boolean, FileShareMode, FileCreationDisposition) Initializes a new instance of the FileStreamBuf class
Top
Properties
  Name Description
Public property FileName This property represents name of the file associated with this stream buffer.
(Overrides StreamBufFileName)
Public property IsEof This property indicates whether current position of the file pointer for this stream buffer is at the end of file.
(Overrides StreamBufIsEof)
Public property Length This property represents the length in bytes of the file associated with this stream buffer.
(Overrides StreamBufLength)
Public property ShareMode This property represents the share mode for this stream buffer object. It can be: ValueDescription0x10 deny read/write mode 0x20 deny write mode 0x30 deny read mode 0x40 deny none mode
(Overrides StreamBufShareMode)
Public property Tell This property represents the current position of the file pointer for this stream buffer.
(Overrides StreamBufTell)
Top
Methods
  Name Description
Public method CopyTo(StreamBuf, UInt64, UInt64) Copies bytes from this stream buffer to the specified stream buffer.
(Overrides StreamBufCopyTo(StreamBuf, UInt64, UInt64))
Public method Read Reads a byte at current position of a file pointer.
(Overrides StreamBufRead)
Public method Read(UInt32) Reads the specified number of bytes at current position of a file pointer.
(Overrides StreamBufRead(UInt32))
Public method Rewind Sets the current position of the file pointer for this stream buffer to zero.
(Overrides StreamBufRewind)
Public method Seek Moves the current position of the file pointer for this stream buffer object to the specified location.
(Overrides StreamBufSeek(Int64, FilerSeekType))
Public method Truncate Sets the length of the file associated with this stream buffer object to zero.
(Overrides StreamBufTruncate)
Public method Write(Byte) Writes the byte to the current position of the file pointer for this stream buffer, and increments the pointer.
(Overrides StreamBufWrite(Byte))
Public method Write(Byte, UInt32) Writes the specified amount of bytes to the current position of the file pointer for this stream buffer, and increments the pointer by the specified amount.
(Overrides StreamBufWrite(Byte, UInt32))
Top
See Also

©  Bricsys NV. All rights reserved.