GIRasterImage Class

Represents the available types of BSP information to visualize with the BSP diagnostic mode.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceGIRasterImage
          Teigha.GraphicsInterfaceGIRasterImageDesc

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class GIRasterImage : RXObject

The GIRasterImage type exposes the following members.

Constructors
  Name Description
Protected method GIRasterImage Initializes a new instance of the GIRasterImage class
Top
Properties
  Name Description
Public property ColorDepth  
Public property imageSource Property that represents the source of a raster image.
Public property ImgTransparencyMode  
Public property NumColors  
Public property PaletteDataSize  
Public property PixelHeight  
Public property PixelWidth  
Public property ScanLinesAlignment  
Public property ScanLineSize  
Public property TransparentColor  
Top
Methods
  Name Description
Public methodStatic member CalcBMPScanLineSize Retrieves the size of a single scanline in BMP format for this raster image object.
Public method ChangeImageSource Sets a new image source and returns a handle to this raster image.
Public method ChangeTransparencyMode Sets the transparency mode for 32bpp formats and returns a handle to this raster image.
Public method Convert(Boolean) Converts the palette of this image to RGB (if convertPaletteToRGB is set to true) and returns a handle to the converted image.
Public method Convert(Boolean, Double) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Convert(Boolean, Double, Double) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Convert(Boolean, Double, Double, Double) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Convert(Boolean, Double, Double, Double, Color) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean, GIRasterImage) Converts this raster image according to the specified parameters and returns a handle to the converted image.
Public method Crop Crops this raster image using a rectangle and returns a handle to this raster image. The format of the returned raster image is identical to the format of the source raster image.
Public method DefaultResolution  
Protected method DeleteUnmanagedObject
(Overrides RXObjectDeleteUnmanagedObject)
Public method getColor Retrieves the color for the specified index from the palette of this raster image object.
Public method PaletteData Retrieves the palette in BMP format of this raster image object.
Public method pixelFormat Retrieves the pixel format for this raster image object, unless there is no palette, in which case it returns the pixel format of the image itself.
Public method ScanLines Retrieves the set of scanlines in BMP format from this raster image object.
Public method ScanLines(Int32, Int32) Retrieves the specified set of scanlines in BMP format from this raster image object.
Top
See Also

©  Bricsys NV. All rights reserved.