PointCloudCrop Class

This class represents cropping boundaries for point cloud entities.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesPointCloudCrop

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class PointCloudCrop : DisposableWrapper

The PointCloudCrop type exposes the following members.

Constructors
  Name Description
Public method PointCloudCrop Default constructor for the PointCloudCrop class. Creates an undefined crop region.
Top
Properties
  Name Description
Public property CropPlane Property that represents a plane on which this point cloud crop region is defined.
Public property CropType Property that represents a type of this point cloud crop region.
Public property Inside Property that indicates whether this cropping boundary allows points inside the region.
Public property Inverted Property that indicates whether this cropping boundary results should be inverted.
Public property Vertices Property that represents a collection of vertices that compose this point cloud crop region.
Top
Methods
  Name Description
Public method Clear Clears this point cloud cropping boundary.
Public methodStatic member Create Creates a PointCloudCrop object. If the specified parameter is IntPtr::Zero, creates a non-binded PointCloudCrop. If the passed parameter is a valid OdDbPointCloudCropping pointer, binds the created PointCloudCrop with it.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Protected method Dispose(Boolean) Releases the unmanaged resources used by the PointCloudCrop and optionally releases the managed resources
(Overrides DisposableWrapperDispose(Boolean))
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method IsValid Checks whether this point cloud cropping boundary is valid.
Top
See Also

©  Bricsys NV. All rights reserved.