param:constraint-get-arguments


(param:constraint-get-arguments  constraint)

Returns the constraints arguments for the specified constraint (integer).

Arguments

constraint (integer) the constraint to query

Return

list of 1 or 2 definition entries, or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(setq args (mech:constraint-get-arguments constraint))  
((NIL (1 2 <Entity name: a3faedf0>)) (NIL (1 2 <Entity name: a3faef40>)))

Remarks

definition entry uses format : (CoordinateSystemType SubEntityDefinitionList)

please see (mech:addconstraint)

Note

this function returns the definition entities, and their related CoordinateSystem type



©  Bricsys NV. All rights reserved.