param:constraint-get-blockid


(param:constraint-get-blockid  constraint)

Returns the BlockTableRecord referenced by the specified constraint (integer).

Arguments

constraint (integer) the constraint to query

Return

ename or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(setq blkId (mech:constraint-get-blockid constraint))  <Entity name: a44ce8c0>

Remarks


Note




©  Bricsys NV. All rights reserved.