param:constraint-get-directions


(param:constraint-get-directions  constraint)

Returns the direction mode of the specified constraint (integer).

Arguments

constraint (integer) the constraint to query

Return

integer (one of  3DConstraints Directions values) or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(mech:constraint-get-directions constraint)  0

Remarks


Note




©  Bricsys NV. All rights reserved.