param:constraint-get-dimension


(param:constraint-get-dimension  constraint)

Returns whether the specified 'constraint' (integer) is dimensional or not.

Arguments

constraint (integer) the constraint to query

Return

T or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(setq dimobj (mech:constraint-get-dimension constraint))  NIL

Remarks

see function (mech:constraint-get-isdimensional)

Note




©  Bricsys NV. All rights reserved.