param:constraint-get-name


(param:constraint-get-name  constraint)

Returns the name of the specified constraint (integer).

Arguments

constraint (integer) the constraint to query

Return

the name of the constraint (string), or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(mech:constraint-get-name constraint)  "Coincident_1"

Remarks


Note




©  Bricsys NV. All rights reserved.