param:constraint-get-parameter


(param:constraint-get-parameter  constraint)

Returns the constraint parameter for the specified constraint (integer).

Arguments

constraint (integer) the constraint to query

Return

integer (ParameterVariable identifier) or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a40c9010>
(setq grp (mech:get-constraintsgroup blkId))  2685508064
(setq constraints (mech:get-constraints grp))  (2685508640 2685507680)
(setq constraint (nth 0 constraints))  2685508640
(setq param (mech:constraint-get-parameter constraint))  2685512960

Remarks

for "ParameterVariable" see Mechanical Parameter functions

Note




©  Bricsys NV. All rights reserved.