param:constraint-get-placement


(param:constraint-get-placement  constraint  argIndex)

Returns the placement mode of the specified constraint (integer) for the argIndex (integer, 0/1).

Arguments

constraint (integer) the constraint to query

argIndex (integer) 0 or 1, refering to the first or second definition entity

Return

integer (one of the 3DConstraints Placement values), or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: a44cefc0>
(setq grp (mech:get-constraintsgroup blkId))  2684693328
(setq constraints (mech:get-constraints grp))  (2684692368)
(setq constraint (nth 0 constraints))  2684692368
(setq place (mech:constraint-get-placement constraint 0))  NIL

Remarks

not all constraint types need or use a "geometric placement" like Inside, Outside, Any

Note




©  Bricsys NV. All rights reserved.