param:get-sketchplane


(param:get-sketchplane  constraintsGroup)

Returns the 2D SketchPlane (if any) for the specified constraintsGroup (integer).

Arguments

constraintsGroup (integer) the constraints group to query for the 'Sketch Plane'

Return

list of (originPoint normalVector) specifying the sketch plane, or NIL if no sketch plane is used

Example

(vl-load-mech)  2
(setq res ((param:get-allconstraintsgroups))  (2698242080 2698242176)
(setq grp (car res))  2698242080
(setq res ((param:has-sketchplane grp))  T
(setq res ((param:get-sketchplane grp))  ((0 0 0) (0 0 1))

Remarks

see functions (param:get-allconstraintsgroups) and (param:get-constraintsgroup) to retrieve the constraintsGroup;
see also (param:has-sketchplane)

Note




©  Bricsys NV. All rights reserved.