param:parameters-get-blockid


(param:parameters-get-blockid  parameter)

Returns the owning BlockTableRecord of the specified parameter (integer).

Arguments

parameter (integer) the parameter identifier

Return

BlockTableRecord (ename) or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: 4aaad770>
(setq params (mech:parameters-get-fromblock blkId))  (2095012000)
(setq param (car params))  2095012000
(mech:parameters-get-blockid param)  <Entity name: 4aaae230>

Remarks


Note




©  Bricsys NV. All rights reserved.