param:parameters-get-byname


(param:parameters-get-byname  blkId  name  [ create ])

Returns the 3DConstraint parameter with name (string) of BlockTableRecord blkId (ename); if create is non-NIL, such a parameter is created, if not yet existing.

Arguments

blkId (ename) the BlockTableRecord (block definition) to be queried

name (string) name of the parameter to retrieve

create (T/NIL)  if non-NIL, a new parameter object with name is created for the specified blkId BlockTableRecord, if not such parameter already exist

Return

integer (parameter identifier), or NIL

Example

(vl-load-mech)  2
(setq blkId (tblobjname "BLOCK" "*Model_Space"))  <Entity name: 4aaa68b0>
(setq param (mech:parameters-get-byname blkId "Length"))  971708080

Remarks


Note




©  Bricsys NV. All rights reserved.