DimStyle

Works with Bricscad (Windows) Classic and Pro, Bricscad (Linux) Classic

Creates and modifies dimension styles, through the Drawing Explorer.

Accessing the Command

command bar:  DimStyle

aliases:  d, ddim, dimsty, ds, dst, expdimstyles, setdim

menu bar:  Settings | Dimension Style

toolbar:  Dimensions |

status bar:  Standard (or name of other  current dimension style)

 

: dimstyle

Displays the Drawing Explorer at the Dimension Styles section:

Create or edit dimension styles, and then click X.

Press F1 to access help.

 

<Overrides> - allows dimension settings to be overriden, without creating a new style.

*Standard - lists the dimension settings for the dimension style named "Standard"; the * asterisk indicates that this is the current style.

Command Options

Option

Description

Name

Names of the dimension style; all styles can be renamed and deleted, except for the Standard style.

 

 

Description

Arrow 1

Specifies the style of arrowhead for the starting end of the dimension line; choose from one of the following types:

Arrow 2

Specifies the style of arrowhead for the other end of the dimension line.

Arrow Size

Specifies the length of the arrowhead; the width is scaled proportionately.

Leader Arrow

Specifies the style of arrowhead for the starting end of the leader line.

Dim Line Color

Specifies the color of the dimension line; choose from:

  • Any Index Color.

  • Any True Color.

  • ByBlock.

  • ByLayer.

Dim Line type

Specifies the line type of the dimension line; choose from any line type loaded into the current drawing.

To access additional linetypes, click Load, and then choose one from the Load Linetypes dialog box.

Dim Line LW

Specifies the lineweight of the dimension line; choose from any lineweight supported by Bricscad.

Dim Line Ext

Specifies the distance that the dimension line extends beyond the extension lines.

Dim Baseline Spacing

Specifies the default distance between dimensions added with the DimBaseline command.

Dim Line 1

Toggles the display of the first half of the dimension line (between the starting extension line and the text).

Dim Line 2

Toggles the display of the second half of the dimension line (between the other extension line and the text).

Ext Line Color

Specifies the color of the dimension line; choose from:

  • Any Index Color.

  • Any True Color.

  • ByBlock.

  • ByLayer.

Ext Line type

Specifies the line type of both extension lines; choose from any line type loaded into the current drawing.

To access additional linetypes, click Load, and then choose one from the Load Linetypes dialog box.

Ext Line LW

Specifies the lineweight of the extension line; choose from any lineweight supported by Bricscad.

Ext Line Ext

Specifies the distance that the extension lines extend beyond the dimension line.

Ext Line Offset

Specifies the offset distance between the object and the start of the extension lines.

Ext Line 1

Toggles the display of the first extension line.

Ext Line 2

Toggles the display of the second extension line.

Ext line type 1

Specifies the line type of the first extension line; choose from any line type loaded into the current drawing.

To access additional linetypes, click Load, and then choose one from the Load Linetypes dialog box.

Ext line type 2

Specifies the line type of the second extension line; choose from any line type loaded into the current drawing.

To access additional linetypes, click Load, and then choose one from the Load Linetypes dialog box.

Ext line fixed length

Specifies the length of fixed-length extension lines.

Center Mark

Specifies the type of center mark:

  • Mark.

  • Line.

  • None.

Center Mark Size

Specifies the size of the center mark.

Arc length symbol

Specifies the location of the arc length symbol:

  • Preceding dimension text.

  • Above dimension text.

  • Not displayed.

Jog angle

Specifies the angle of the jog; default is 45 degrees.

Enter another angle.

 

Description

 

Text Style

Specifies the style for dimension text; can use only styles created with the Style command.

Text Color

Specifies the color of the text; choose from:

  • Any Index Color.

  • Any True Color.

  • ByBlock.

  • ByLayer.

Text Fill

Determines whether the dimension text has a rectangular background filled with color.

Choose from:

  • No fill - does not apply a background fill.

  • Background - uses the background color of the drawing, usually white or black.

  • Color - uses the color specified by the Text Fill Color option.

Text Fill Color

Specifies the background fill color when Text Fill is set to Color.

Choose a color from the drop list, or click Select Color to access the Select Color dialog box.

Text Height

Specifies the height of the text.

Draw Frame Around Text

Toggles a rectangle around the text.

Text Pos Vert

Justifies the text vertically relative to the dimension line:

  • Centered - centers the text on the dimension line.

  • Above - places the text above the dimension line.

  • Outside - places text outside of the extension lines.

  • JIS - generally places text above the dimension line, according to the Japanese Industry Standard.

Text Pos Hor

Justifies the text horizontally relative to the extension lines:

  • Centered - centers the text between the extension lines.

  • First Extension Line - places the text near the first extension line.

  • Second Extension Line - places the text near the second extension line.

  • Over First Extension - places the text over the first extension line.

  • Over Second Extension - places the text over the second extension line.

Text Offset

Specifies the size of gap between the dimension line and the text.

Text Inside Align

Justifies text when located between extension lines:

  • Aligned with Dimension Line - aligns text with dimension line.

  • Horizontal - forces text to be always horizontal.

Text Outside Align

Justifies text when located outside of the extension lines:

  • Aligned with Dimension Line - align text with dimension line.

  • Horizontal - forces text to be always horizontal.

 

Description

Arrow and Text Fit

Specifies where text and arrows should be located when there is insufficient space for both between the extension lines:

  • Text and Arrows - forces both text and arrows between the extension lines.

  • Arrows Only - forces arrows to stay within extension lines; moves text outside when there is insufficient space.

  • Text Only - forces text to stay within extension lines; moves arrows outside when there is insufficient space.

  • Best Fit - requires Bricscad to figure out where to place text and arrows, depending on the space between extension lines.

Text Inside

Toggles whether the text is forced between extension lines:

  • On - forces text between extension lines.

  • Off - draws text outside, if insufficient space between extension lines.

Dim Line Inside

Toggles whether the dimension line is forced between extension lines:

  • On - forces dimension line always between extension lines.

  • Off - draws dimension line outside, if insufficient space between extension lines.

Text Movement

Specifies what happens when text is moved away from its default location:

  • Keep dim line with text - moves dimension line with the text, stretching the extension lines.

  • Move text, add leader - draws a leader between the text and the dimension line.

  • Move text, no leader - does not draw a leader.

Dim Scale Overall

Specifies the overall scale factor for dimensions; this affects the size of arrows and text only.

Place Text Manually

Toggles whether the user must always specify the text location when creating dimensions.

Dim Line Forced

Forces the dimension line to be always drawn; forces leaders to be drawn with the DimDiameter and DimRadius commands.

 

Description

Dim Units

Specifies the display units for dimensions:

  • Scientific -  scientific notation, such as 1.2345E+01.

  • Decimal - metric, such as 1.2345.

  • Engineering - feet and decimal inches, such as 1'-2.3456".

  • Architectural - feet and fractional inches, such as 1'-2 1/16".

  • Fractional - fractional inches only; no feet, such as 14 1/16".

  • Windows Desktop - uses the units set by Windows.

Dim Precision

Specifies the precision of units, either decimal places or fractional accuracy.

Fractional Type

Specifies how fractions are stacked:

  • Horizontal - stacks fractions vertically, with a horizontal separator line.

  • Diagonal - stack stacks diagonally, with a diagonal separator line.

  • None - does not stack fractions, placed horizontally with a slash separator.

Decimal Separator

Specifies the character used to indicate the decimal point; can be any character.

North American countries use the period; European countries use the comma.

Dim Round

Specifies the rounding of decimal numbers; range is none to 8 decimal places.

Dim Prefix

Specifies prefix text that appears in front of the dimension text, if any.

Dim Suffix

Specifies suffix text that appears after the dimension text, if any.

Dim Scale Linear

Specifies the multiplier for dimension values, such as 25.4 for changing inches to millimeters.

Suppress Leading Zeros

Toggles the display of zeros in front of the decimal point; for example, 0.23 is displayed as:

  • On - .23

  • Off - 0.23

Suppress Trailing Zeros

Toggles the display of zeros in front of the decimal point; for example, 1.2300 is displayed as:

  • On - 1.23

  • Off - 1.2300

Suppress Zero Feet

Toggles the display of zero feet; for example, 0'-3" is displayed as:

  • On - 3"

  • Off - 0'-3"

Suppress Zero Inches

Toggles the display of zero inches; for example, 1'-0" is displayed as:

  • On - 1'

  • Off - 1'-0"

Dim Angle Units

Specifies the format of units in angular dimensions:

  • Decimal Degrees - 360 degrees in a circle; for example, 123.45 degrees

  • Deg/Min/Sec - degrees, minutes, seconds; for example, 123d 12' 45.67".

  • Grads - 400 grads in a circle; for example, 230g.

  • Rads - 2pi radians in a circle; for example, 1.5r.

Dim Angle Precision

Specifies the number of decimal places; ranges from 0 to 8.

Suppress Angle Leading Zeros

Toggles the display of zero degrees; for example, 0.1234 degrees is displayed as:

  • On - .1234

  • Off - 0.1234

Suppress Angle Trailing Zeros

Toggles the display of zeros after degrees; for example, 0.1200 degrees is displayed as:

  • On - 0.12

  • Off - 0.1200

 

Description

Alternate Enabled

Toggles the display of alternative units:

  • On - second, alternative units displayed to the right of primary units.

  • Off - only primary units are displayed.

Alt Units

Specifies the display units for dimensions:

  • Scientific -  scientific notation, such as 1.2345E+01.

  • Decimal - metric, such as 1.2345.

  • Engineering - feet and decimal inches, such as 1'-2.3456".

  • Architectural - feet and fractional inches, such as 1'-2 1/16".

  • Fractional - fractional inches only; no feet, such as 14 1/16".

  • Windows Desktop - uses the units set by Windows.

Alt Precision

Specifies the precision of units, either decimal places or fractional accuracy.

Alt Scale Factor

Specifies the multiplier for alternate values, such as 25.4 for showing millimeters (alternate units) next to inches (primary units).

Alt Round

Specifies the rounding of alternate numbers; range is none to 8 decimal places.

Alt Prefix

Specifies prefix text that appears in front of the alternate text, if any.

Alt Suffix

Specifies suffix text that appears in after the alternate text, if any.

Alt Leading Zeros

Toggles the display of zeros in front of the decimal point; for example, 0.23 is displayed as:

  • On - .23

  • Off - 0.23

Alt Trailing Zeros

Toggles the display of zeros in front of the decimal point; for example, 1.2300 is displayed as:

  • On - 1.23

  • Off - 1.2300

Alt Zero Feet

Toggles the display of zero feet; for example, 0'-3" is displayed as:

  • On - 3"

  • Off - 0'-3"

Alt Zero Inches

Toggles the display of zero inches; for example, 1'-0" is displayed as:

  • On - 1'

  • Off - 1'-0"

 

Description

Tolerance Display

Toggles the display of tolerance text.

Tolerance Precision

Specifies the display precision of tolerance text; range is 0 to 8 decimal places or 1/1 to 1/256 inch.

Tolerance Limit Lower

Specifies the value of the upper tolerance.

Tolerance Limit Upper

Specifies the value of the lower tolerance.

Tolerance Text Height

Specifies the height of tolerance text.

Tolerance Pos Vert

Locates the tolerance text relative to the dimension text:

  • Bottom - aligns tolerance text with the bottom of the dimension text.

  • Middle - aligns tolerance text  with the middle of the dimension text.

  • Top - aligns tolerance text with the top of the dimension text.

Tolerance Suppress Leading Zeros

Toggles the display of zeros in front of the decimal point.

Tolerance Suppress Trailing Zeros

Toggles the display of zeros behind the decimal point.

Tolerance Suppress Zero Feet

Toggles the display of zero feet.

Tolerance Suppress Zero Inches

Toggles the display of zero inches.

Alt Tolerance Precision

Specifies the number of decimal places for tolerances in alternate units.

Alt Tolerance Suppress Leading Zeros

Toggles the display of zeros in front of the decimal point.

Alt Tolerance Suppress Trailing Zeros

Toggles the display of zeros behind the decimal point.

Alt Tolerance Suppress Zero Feet

Toggles the display of zero feet.

Alt Tolerance Suppress Zero Inches

Toggles the display of zero inches.

Status Bar Menu

Right-click Standard (or other dimension style name) on the status bar for the shortcut menu:

    

Shortcut Menu

Description

Standard

Chooses the default dimension style.

When the drawing contains additional dimension styles, their names are listed here.

Properties

 

Opens the Dimension Styles section of the Drawing Explorer.


Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV are fully owned subsidiaries of Menhirs NV. Copyright © 2001- Menhirs NV - All rights reserved.