IAcSmComponent


The Sheet Component interface.

available methods :

(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument cad))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))

(setq sheetset (vlax-invoke-method smdb 'GetSheetSet))

GetName

returns the name property of this component

(setq res (vlax-invoke-method sheetset 'GetName))

HRESULT GetName ([out, retval] BSTR* name)

SetName

assigns the name property for this component

(setq res (vlax-invoke-method sheetset 'SetName "TestComponent"))

HRESULT SetName ([in] BSTR name)

GetDesc

returns the description property of this component

(setq res (vlax-invoke-method sheetset 'GetDesc))

HRESULT GetDesc ([out, retval] BSTR* desc)

SetDesc

assigns the description property for this component

(setq res (vlax-invoke-method sheetset 'SetDesc "test description"))

HRESULT SetDesc ([in] BSTR desc)

GetCustomPropertyBag

returns the custom property bag of this component

(setq propsbag (vlax-invoke-method sheetset 'GetCustomPropertyBag))

HRESULT GetCustomPropertyBag ([out, retval] IAcSmCustomPropertyBag** bag)



©  Bricsys NV. All rights reserved.