IAcSmProjectPointLocation


The Sheet ProjectPoint Location interface.

available methods :

(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument cad))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq ppLocations (scanUntilObject iter "AcSmProjectPointLocations"))
(vlax-invoke-method ppLocations 'AddNewLocation "NewLocation" "www.newlocation.org" "c:\\anyfolder" "user" "pwd" 'ppLoc))

Note : "(scanUntilObject)" is a utility function contained in the sample Lisp files in folder "<LDSP>/SheetSetManager-Lisp-API/LISP Sample Code"

GetName

returns the name of this ProjectPointLocation

(vlax-invoke-method ppLoc 'GetName 'name)

HRESULT GetName ([out] BSTR* name)

SetName

assigns the name for this ProjectPointLocation

(vlax-invoke-method ppLoc 'SetName "New Location 2")

HRESULT SetName ([in] BSTR name)

GetURL

returns the URL of this ProjectPointLocation

(vlax-invoke-method ppLoc 'GetURL url)

HRESULT GetURL ([out] BSTR* url)

SetURL

assigns the URL for this ProjectPointLocation

(vlax-invoke-method ppLoc 'SetURL "www.newlocation-2.org")

HRESULT SetURL ([in] BSTR url)

GetFolder

returns the file system folder of this ProjectPointLocation

(vlax-invoke-method ppLoc 'GetFolder folder)

HRESULT GetFolder ([out] BSTR* folder)

SetFolder

assigns the file system folder for this ProjectPointLocation

(vlax-invoke-method ppLoc 'SetFolder "c:\\anyfolder-2")

HRESULT SetFolder ([in] BSTR folder)

GetUsername

returns the user name of this ProjectPointLocation

(vlax-invoke-method ppLoc 'GetUsername username)

HRESULT GetUsername ([out] BSTR* username)

SetUsername

assigns the user name for this ProjectPointLocation

(vlax-invoke-method ppLoc 'SetUsername "user-2")

HRESULT SetUsername ([in] BSTR username)

GetPassword

returns the password of this ProjectPointLocation

(vlax-invoke-method ppLoc 'GetPassword password)

HRESULT GetPassword ([out] BSTR* password)

SetPassword

assigns the password for this ProjectPointLocation

(vlax-invoke-method ppLoc 'SetPassword "pwd-2")

HRESULT SetPassword ([in] BSTR password)



©  Bricsys NV. All rights reserved.