IAcSmDatabase
The main SheetSet Database
interface.
available methods :
(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
LoadFromFile |
(re-)loads from the specified
DST template database, or re-initialise from assigned DST database
file if no template is specified (as "0") |
GetFileName |
returns the DST file that
this database is associated with |
SetFileName |
assigns the DST file that
this database is associated with (only once; after a new
IAcSmDatabase was constructed) |
GetTemplateDstFileName |
returns the template DST file
that was used with 'LoadFromFile' |
GetSheetSet |
returns the IAcSmSheetSet
component managed by this IAcSmDatabase |
LockDb |
locks this IAcSmDatabase to
allow modifications of the specified object |
UnlockDb |
unlocks this IAcSmDatabase
(after all modifications are done), optionally (default) commits to
the disk file |
GetLockStatus |
returns the locking status
for this IAcSmDatabase |
GetLockOwnerInfo |
returns informations on the
owner of the current lock |
GetNewObjectId |
returns the IAcSmObjectId (or
creates it, if necessary) for the specified object
handle |
RegisterOwner |
defines the owner for the
provided IAcSmPersist object to create object
hierarchies |
GetEnumerator |
returns an enumerator
(iterator) object for this IAcSmDatabase (iterating all contained
objects) |
FindObject |
returns the IAcSmPersist
object for the specified persistent object handle |
FindAcDbObjectReferences |
returns an array of
IAcSmAcDbObjectReference objects that reference the specified
AcDbObject database object |
UpdateInMemoryDwgHints |
updates the hints in all open
drawings referenced by this IAcSmDatabase |
GetIsTemporary |
returns whether this
IAcSmDatabase is persistent or not |
SetIsTemporary |
defines this IAcSmDatabase as
not being persistent |
GetDbVersion |
returns the IAcSmDatabase
version |
© Bricsys NV. All rights reserved. |