IAcSmSheetSetMgr
The main SheetSetManager interface.
available methods :
(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
CreateDatabase |
creates a new DST database
with specified filename, optionally using a .dst template file and
a boolean flag whether to always (re-)create if already existing;
returns the IAcSmDatabase object |
OpenDatabase |
opens the specified existing
DST database file, optionally using a boolean flag whether to open
an already opened DST file; returns the IAcSmDatabase
object |
FindOpenDatabase |
queries the SheetSetManager
for the specified, already opened DST database file ; returns the
IAcSmDatabase object, or NIL |
CloseAll |
closes all currently open DST
database objects (IAcSmDatabase) |
Close |
closes the specified DST
database object (IAcSmDatabase) |
GetParentSheetSet |
searches the main SheetSet
for the given layout in the specified dwg file; returns the
IAcSmSheetSet object (if found) by reference, and the IAcSmDatabase
object as return value |
GetSheetFromLayout |
searches the main SheetSet
for the given layout object (IAcadLayout); returns the
IAcSmSheetSet object (if found) by reference, and the IAcSmDatabase
object as return value |
GetDatabaseEnumerator |
returns an iterator
(IAcSmEnumDatabase) for all opened DST databases managed by the
SheetSetManager |
© Bricsys NV. All rights reserved. |