IAcSmEnumAcDbBlockRecordReference
The Enumerator for
IAcSmAcDbBlockRecordReference objects.
available methods :
(setq cad (vlax-get-acad-object))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
(setq iter (vlax-invoke-method smdb
'GetEnumerator))
(setq calloutBlocks (scanUntilObject iter
"AcSmCalloutBlocks"))
(setq iter (vlax-invoke-method calloutBlocks
'GetEnumerator))
Note : "(scanUntilObject)" is a utility
function contained in the sample Lisp files in folder
"<LDSP>/SheetSetManager-Lisp-API/LISP Sample Code"
Next |
iterates to the next and
returns the actual element |
Reset |
resets the enumerator to the
first element |
© Bricsys NV. All rights reserved. |