IAcSmSheetResources
The Sheet Resources interface (collection of
IAcSmFileReference objects).
available methods :
(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument
cad))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
(setq iter (vlax-invoke-method smdb
'GetEnumerator))
(setq resources (scanUntilObject iter
"AcSmResources"))
Note : "(scanUntilObject)" is a utility
function contained in the sample Lisp files in folder
"<LDSP>/SheetSetManager-Lisp-API/LISP Sample Code"
Add |
adds the provided
IAcSmFileReference component to this collection |
Remove |
removes the specified
IAcSmFileReference component from this collection |
GetEnumerator |
returns an enumerator for the
IAcSmFileReference components in this collection |
© Bricsys NV. All rights reserved. |